THE EXTENSIONS ARE FIXED

Post Reply
User avatar
Reality Check
Posts: 16560
Joined: Fri Feb 20, 2009 8:09 pm
Location: USA
Contact:

Re: I TOLD YOU THIS WAS HAPPENING

#126

Post by Reality Check »

If I am reading correctly the media embed extension is now working but the advanced BBCode extension is not. Is that correct?
"“If you’re not outraged, you’re not paying attention.”

Heather Heyer, November 2016
User avatar
jmj
Posts: 915
Joined: Wed Mar 09, 2016 11:01 am

Re: I TOLD YOU THIS WAS HAPPENING

#127

Post by jmj »

neeneko wrote: Fri Aug 21, 2020 8:55 am
NMgirl wrote: Thu Aug 20, 2020 9:16 pm Staying logged in no longer appears to be an option for me. But that’s ok. Remembering my password every time I want to make a comment is practice for one of those memory quizzes at which trump excels.
It looks like it might be related to the https/http change. I've found that if I go to the http version of the site I have to log back in, and it only keeps me logged in till I close all related tab. However if I am careful about what goes into my address bar and ONLY go to the https port, I stay logged in.

So the site probably needs a http->https redirect to prevent browsers from interacting with the non-secure version and mixing the cookie types. I think. Web stuff is not exactly my wheel well.
I was going to say the same thing. Really, the website should enforce https-only access and disable/redirect plain http. Those of us who have been using https already don't seem to be having any problems.
User avatar
Foggy
Posts: 31646
Joined: Tue Jan 20, 2009 12:00 pm
Location: District Court of Bun-Dogs
Occupation: Devilish Hyena
Avatar: Silly engineers have been using 3D printers to make Godzilla arms for chickens.

Re: I TOLD YOU THIS WAS HAPPENING

#128

Post by Foggy »

Reality Check wrote: Fri Aug 21, 2020 9:49 am If I am reading correctly the media embed extension is now working but the advanced BBCode extension is not. Is that correct?
No, if I enable the Media Embed extension you get a blank page on the Board Index page and if you try to write a post. I'm still working on that.

Yes, I implemented https a while back, but a 500 error is a server error, so I looked through all the server settings on the software, and it said if you use https, you also should use "secure" cookies, so I did that, but it should only cause problems for a few days.

More will be revealed. I may try some new solutions today and tomorrow.

Today is the last weekday that my swim club opens at 11. The lifeguards are all back in school - online, but still. So I'm out the door and will be returning later on ...
I hope y'all are still wearing your seat belts!
User avatar
Reality Check
Posts: 16560
Joined: Fri Feb 20, 2009 8:09 pm
Location: USA
Contact:

Re: I TOLD YOU THIS WAS HAPPENING

#129

Post by Reality Check »

Foggy wrote: Fri Aug 21, 2020 10:48 am :snippity:
No, if I enable the Media Embed extension you get a blank page on the Board Index page and if you try to write a post. I'm still working on that.
I noticed after I posted that tweets and videos were not showing.

Good luck and keep plugging away. I am confident you will eventually fix the board.
"“If you’re not outraged, you’re not paying attention.”

Heather Heyer, November 2016
User avatar
kate520
Posts: 16795
Joined: Mon Oct 26, 2009 3:02 pm
Location: Dark side of the Moon
Occupation: servant of cats, chicken wrangler
Contact:

Re: I TOLD YOU THIS WAS HAPPENING

#130

Post by kate520 »

Thanks, boss. :bighug:
DEFEND DEMOCRACY
User avatar
MRich
Posts: 876
Joined: Sun Aug 22, 2010 4:07 pm

Re: I TOLD YOU THIS WAS HAPPENING

#131

Post by MRich »

MRich wrote: Thu Aug 20, 2020 7:46 pm I was having a problem having to log in multiple times. It seems it was my browser bookmarks. The update added a bunch of letters and numbers onto the link. For example:

Code: Select all

UNREAD POSTS
Before: http://www.thefogbow.com/forum/search.php?search_id=unreadposts
After: http://www.thefogbow.com/forum/search.php?search_id=unreadposts&sid=276f286b139b6aaa38b32acfc779b8a8
So, I am just updating the bookmarks.
Spoke too soon - that big alphanumeric after the "&sid=" changes (maybe each time I launch my browser?). So my bookmarks directly to certain forums won't work at this time. Sorry if I confused anyone.
chancery
Posts: 1756
Joined: Sat Nov 07, 2009 5:51 pm

Re: I TOLD YOU THIS WAS HAPPENING

#132

Post by chancery »

ZekeB wrote: Fri Aug 21, 2020 8:00 am Meh. The original avatar is classic Sterngard. Tis the only avatar I've ever seen you with. If you change your avatar it would be like you growing a beard - I wouldn't recognize you.
:like:
User avatar
jmj
Posts: 915
Joined: Wed Mar 09, 2016 11:01 am

Re: I TOLD YOU THIS WAS HAPPENING

#133

Post by jmj »

MRich wrote: Fri Aug 21, 2020 9:32 pm
MRich wrote: Thu Aug 20, 2020 7:46 pm I was having a problem having to log in multiple times. It seems it was my browser bookmarks. The update added a bunch of letters and numbers onto the link. For example:

Code: Select all

UNREAD POSTS
Before: http://www.thefogbow.com/forum/search.php?search_id=unreadposts
After: http://www.thefogbow.com/forum/search.php?search_id=unreadposts&sid=276f286b139b6aaa38b32acfc779b8a8
So, I am just updating the bookmarks.
Spoke too soon - that big alphanumeric after the "&sid=" changes (maybe each time I launch my browser?). So my bookmarks directly to certain forums won't work at this time. Sorry if I confused anyone.
I believe that the 'sid' stands for "session ID" and is a way for the site to keep track of your login session. If I remember correctly, this URL parameter is used as an alternative to identifying your login session via cookies. Are you blocking cookies for some reason?
Edit: just to be clear, I don't get the sid parameter in my URL
User avatar
MRich
Posts: 876
Joined: Sun Aug 22, 2010 4:07 pm

Re: I TOLD YOU THIS WAS HAPPENING

#134

Post by MRich »

jmj wrote: Fri Aug 21, 2020 10:07 pm
MRich wrote: Fri Aug 21, 2020 9:32 pm
MRich wrote: Thu Aug 20, 2020 7:46 pm I was having a problem having to log in multiple times. It seems it was my browser bookmarks. The update added a bunch of letters and numbers onto the link. For example:

Code: Select all

UNREAD POSTS
Before: http://www.thefogbow.com/forum/search.php?search_id=unreadposts
After: http://www.thefogbow.com/forum/search.php?search_id=unreadposts&sid=276f286b139b6aaa38b32acfc779b8a8
So, I am just updating the bookmarks.
Spoke too soon - that big alphanumeric after the "&sid=" changes (maybe each time I launch my browser?). So my bookmarks directly to certain forums won't work at this time. Sorry if I confused anyone.
I believe that the 'sid' stands for "session ID" and is a way for the site to keep track of your login session. If I remember correctly, this URL parameter is used as an alternative to identifying your login session via cookies. Are you blocking cookies for some reason?
Edit: just to be clear, I don't get the sid parameter in my URL
Your explanation sounds reasonable, and that's a good question... I am not intentionally blocking cookies on my Firefox browser (I'll keep checking; maybe I did something when I cleared the cookies to enable me to log in), but I am not having this same SID thing occur on my Chrome browser. Thanks for your input!
User avatar
Orlylicious
Posts: 13323
Joined: Mon Apr 23, 2012 4:02 pm
Location: @orly_licious With Pete Buttigieg and the other "open and defiant homosexuals" --Bryan Fischer AFA
Occupation: #StuggersForBiden "Do Nothing Democrat Savage" -- Donald, 9/28/19 and "Scalawag...Part of an extreme, malicious leftist internet social mob working in concert with weaponized, socialized governments to target and injure political opponents.” -- Walt Fitzpatrick
Contact:

Re: I TOLD YOU THIS WAS HAPPENING

#135

Post by Orlylicious »

Foggy wrote: Fri Aug 21, 2020 10:48 am The lifeguards are all back in school
Are you offering us lifeguards?

Image

https://www.elitedaily.com/envision/20- ... os/1045038


And thanks Foggy, we really appreciate all your work keeping Fogbow the best forum anywhere online! :lovestruck:
Avatar: LDIT's Post-election #FAIL record in court. And hey, don't miss The Fogbow's Favourite TV Show™ starring the titular Mama June Shannon! Returns 2021. TVShowsAce featured Fogbow's love 5/26/20: https://bit.ly/2TNxrbS[/b]
User avatar
RTH10260
Posts: 28972
Joined: Tue Mar 02, 2010 8:52 am
Location: Near the Swiss Alps

Re: I TOLD YOU THIS WAS HAPPENING

#136

Post by RTH10260 »

MRich wrote: Sat Aug 22, 2020 10:14 pm
jmj wrote: Fri Aug 21, 2020 10:07 pm
MRich wrote: Fri Aug 21, 2020 9:32 pm

Spoke too soon - that big alphanumeric after the "&sid=" changes (maybe each time I launch my browser?). So my bookmarks directly to certain forums won't work at this time. Sorry if I confused anyone.
I believe that the 'sid' stands for "session ID" and is a way for the site to keep track of your login session. If I remember correctly, this URL parameter is used as an alternative to identifying your login session via cookies. Are you blocking cookies for some reason?
Edit: just to be clear, I don't get the sid parameter in my URL
Your explanation sounds reasonable, and that's a good question... I am not intentionally blocking cookies on my Firefox browser (I'll keep checking; maybe I did something when I cleared the cookies to enable me to log in), but I am not having this same SID thing occur on my Chrome browser. Thanks for your input!
The SID gets assigned freshly when a browser contacts a website for the first time and the user is expected to return. Sometimes it is attached to the URL in the reply, othertimes the website puts it in a cookie to be transparent to the user. If it's in the URL aka web address then you ought to edit a bookmark and remove it. If you add the link to an article you ought to remove it, it's your identification, not someone else to reuse it. The website will decide when to toss and reissue a new one. Also too, the SID is not a standardized name, it depends on the web server. You will recognize the id by having some similar scrambled content of about 30 characters.
Somerset
Posts: 4861
Joined: Sat Aug 08, 2009 5:52 am
Location: Silicon Valley
Occupation: Lab rat

Re: I TOLD YOU THIS WAS HAPPENING

#137

Post by Somerset »

RTH10260 wrote: Sun Aug 23, 2020 12:20 am
MRich wrote: Sat Aug 22, 2020 10:14 pm
jmj wrote: Fri Aug 21, 2020 10:07 pm

I believe that the 'sid' stands for "session ID" and is a way for the site to keep track of your login session. If I remember correctly, this URL parameter is used as an alternative to identifying your login session via cookies. Are you blocking cookies for some reason?
Edit: just to be clear, I don't get the sid parameter in my URL
Your explanation sounds reasonable, and that's a good question... I am not intentionally blocking cookies on my Firefox browser (I'll keep checking; maybe I did something when I cleared the cookies to enable me to log in), but I am not having this same SID thing occur on my Chrome browser. Thanks for your input!
The SID gets assigned freshly when a browser contacts a website for the first time and the user is expected to return. Sometimes it is attached to the URL in the reply, othertimes the website puts it in a cookie to be transparent to the user. If it's in the URL aka web address then you ought to edit a bookmark and remove it. If you add the link to an article you ought to remove it, it's your identification, not someone else to reuse it. The website will decide when to toss and reissue a new one. Also too, the SID is not a standardized name, it depends on the web server. You will recognize the id by having some similar scrambled content of about 30 characters.
How can I get my browsers to disassociate with the "old" unsecure Fogbow site and associate with the secure, https site? All of them, iOS, MacOS and Android still go to the unsecured site and require constant log-in.
User avatar
RTH10260
Posts: 28972
Joined: Tue Mar 02, 2010 8:52 am
Location: Near the Swiss Alps

Re: I TOLD YOU THIS WAS HAPPENING

#138

Post by RTH10260 »

Somerset wrote: Sun Aug 23, 2020 1:19 am Sekrit Stuffs!
RTH10260 wrote: Sun Aug 23, 2020 12:20 am
MRich wrote: Sat Aug 22, 2020 10:14 pm
Your explanation sounds reasonable, and that's a good question... I am not intentionally blocking cookies on my Firefox browser (I'll keep checking; maybe I did something when I cleared the cookies to enable me to log in), but I am not having this same SID thing occur on my Chrome browser. Thanks for your input!
The SID gets assigned freshly when a browser contacts a website for the first time and the user is expected to return. Sometimes it is attached to the URL in the reply, othertimes the website puts it in a cookie to be transparent to the user. If it's in the URL aka web address then you ought to edit a bookmark and remove it. If you add the link to an article you ought to remove it, it's your identification, not someone else to reuse it. The website will decide when to toss and reissue a new one. Also too, the SID is not a standardized name, it depends on the web server. You will recognize the id by having some similar scrambled content of about 30 characters.
How can I get my browsers to disassociate with the "old" unsecure Fogbow site and associate with the secure, https site? All of them, iOS, MacOS and Android still go to the unsecured site and require constant log-in.
Try this: call up the Fogbow as usual, if necessary sign-in. Then look at the browser address bar. You will possibly see a "favourite" marker, or similar highlight that shows that the link is bookmarked. Click on it and when asked discard / remove. Next click into the address bar and you ought to see the protocol marker http://... that may be not displayed. Edit to https://... and hit return. You now ought to get connected to the Fogbow and may again have to sign in. Now save again as bookmark or mark as favourite depending browser.
User avatar
Sugar Magnolia
Posts: 12005
Joined: Sun Apr 01, 2012 6:44 am

Re: I TOLD YOU THIS WAS HAPPENING

#139

Post by Sugar Magnolia »

Somerset wrote: Sun Aug 23, 2020 1:19 am
RTH10260 wrote: Sun Aug 23, 2020 12:20 am
MRich wrote: Sat Aug 22, 2020 10:14 pm
Your explanation sounds reasonable, and that's a good question... I am not intentionally blocking cookies on my Firefox browser (I'll keep checking; maybe I did something when I cleared the cookies to enable me to log in), but I am not having this same SID thing occur on my Chrome browser. Thanks for your input!
The SID gets assigned freshly when a browser contacts a website for the first time and the user is expected to return. Sometimes it is attached to the URL in the reply, othertimes the website puts it in a cookie to be transparent to the user. If it's in the URL aka web address then you ought to edit a bookmark and remove it. If you add the link to an article you ought to remove it, it's your identification, not someone else to reuse it. The website will decide when to toss and reissue a new one. Also too, the SID is not a standardized name, it depends on the web server. You will recognize the id by having some similar scrambled content of about 30 characters.
How can I get my browsers to disassociate with the "old" unsecure Fogbow site and associate with the secure, https site? All of them, iOS, MacOS and Android still go to the unsecured site and require constant log-in.
I finally had to go to google, search for TFB and get to it that way. Then I bookmarked it, logged in and checked 'keep me logged in.' None of my favorites worked after the board upgrade but everything works fine now that I've replaced the links on my favorites.
User avatar
Foggy
Posts: 31646
Joined: Tue Jan 20, 2009 12:00 pm
Location: District Court of Bun-Dogs
Occupation: Devilish Hyena
Avatar: Silly engineers have been using 3D printers to make Godzilla arms for chickens.

Re: FIXING THE EXTENSIONS (thread title edited)

#140

Post by Foggy »

OK, I have struggled and struggled with this thing, I am not done yet.

Today I did manage to add a TWEET code to the board. So if you copy and paste the link to a tweet:

https://twitter.com/McFaul/status/1297397100800425985

... and then highlight the whole link and click the "tweet" button:

Code: Select all

[tweet]https://twitter.com/McFaul/status/1297397100800425985[/tweet]
Then here's what it should show in your post:
I hope y'all are still wearing your seat belts!
User avatar
Foggy
Posts: 31646
Joined: Tue Jan 20, 2009 12:00 pm
Location: District Court of Bun-Dogs
Occupation: Devilish Hyena
Avatar: Silly engineers have been using 3D printers to make Godzilla arms for chickens.

Re: FIXING THE EXTENSIONS (thread title edited)

#141

Post by Foggy »

Still can't figure out a good YouTube BBCode, because the software has changed so much. I'll keep working on that. :daydream:
I hope y'all are still wearing your seat belts!
User avatar
MN-Skeptic
Posts: 3975
Joined: Wed Jan 25, 2012 6:36 pm
Location: Twin Cities

Re: FIXING THE EXTENSIONS (thread title edited)

#142

Post by MN-Skeptic »

:bighug:

You are our hero!
Joe Biden: "Wearing masks is not a political statement. It's a scientific imperative."

It’s the pandemic, stupid!
User avatar
pipistrelle
Posts: 10284
Joined: Wed Oct 19, 2016 11:26 am

Re: FIXING THE EXTENSIONS (thread title edited)

#143

Post by pipistrelle »

User avatar
Foggy
Posts: 31646
Joined: Tue Jan 20, 2009 12:00 pm
Location: District Court of Bun-Dogs
Occupation: Devilish Hyena
Avatar: Silly engineers have been using 3D printers to make Godzilla arms for chickens.

Re: FIXING THE EXTENSIONS (thread title edited)

#144

Post by Foggy »

I hate to say this, but I may have to break down and hire somebody to fix this damn thing. I'm at the limit of my expertise here. :daydream:
I hope y'all are still wearing your seat belts!
User avatar
pipistrelle
Posts: 10284
Joined: Wed Oct 19, 2016 11:26 am

Re: FIXING THE EXTENSIONS (thread title edited)

#145

Post by pipistrelle »

Is there a way to contribute anonymously?
User avatar
Bill_G
Posts: 2037
Joined: Thu Mar 22, 2018 9:10 am
Location: Portland OR
Occupation: I work at being pleasantly surprised everyday.

Re: FIXING THE EXTENSIONS (thread title edited)

#146

Post by Bill_G »

I have customers that request I keep their equipment up-to-date. Honestly, it is not often the upgrade offers any benefit or feature they are looking for. OTOH, the make-it-break, and make-necessary-stuff-disappear often do get installed, and those features are never discussed in the rev notes. That's why I am pretty adamant about a if-it-ain't-broke-don't-fix-it policy. This baptism by fire you are going through is not something I enjoy very much, but I appreciate the boulder you are pushing uphill.
User avatar
NMgirl
Posts: 4827
Joined: Wed Apr 13, 2016 12:02 am

Re: FIXING THE EXTENSIONS (thread title edited)

#147

Post by NMgirl »

Thanks for all your hard work, Foggy. We all so much appreciate your keeping the site up and running. It’s our online home. :bighug:
User avatar
pipistrelle
Posts: 10284
Joined: Wed Oct 19, 2016 11:26 am

Re: FIXING THE EXTENSIONS (thread title edited)

#148

Post by pipistrelle »

Foggy wrote: Sun Aug 23, 2020 7:33 am I hate to say this, but I may have to break down and hire somebody to fix this damn thing. I'm at the limit of my expertise here. :daydream:
What exactly is busted? BBCodes? i found a 2017 post where updating broke BBCodes, but someone named "Crizzo" fixed it. Yeah, a while ago but not uncommon?
User avatar
Reality Check
Posts: 16560
Joined: Fri Feb 20, 2009 8:09 pm
Location: USA
Contact:

Re: FIXING THE EXTENSIONS (thread title edited)

#149

Post by Reality Check »

FFS don't hire the same people who did the last board conversion back to phpBB. :nooo:

I know you will eventually get it done Foggy!
"“If you’re not outraged, you’re not paying attention.”

Heather Heyer, November 2016
User avatar
Volkonski
Posts: 32368
Joined: Sat Mar 02, 2013 4:44 pm
Location: Texoma and North Fork of Long Island
Occupation: Retired Mechanical Engineer
Contact:

Re: FIXING THE EXTENSIONS (thread title edited)

#150

Post by Volkonski »

MN-Skeptic wrote: Sun Aug 23, 2020 7:21 am :bighug:

You are our hero!
:yeah:
Image“If everyone fought for their own convictions there would be no war.”
― Leo Tolstoy, War and Peace
Post Reply

Return to “Announcements”